History

Resolved
June 13, 2023 9:10 PM UTC

AWS servers are back up and running. Teachers and students can now log in to Legends of Learning.

Identified
June 13, 2023 7:15 PM UTC

AWS systems are currently experiencing technical difficulties, which is impacting the ability for teachers and students to access Legends of Learning. We are monitoring the situation and will provide updates.