Awakening Loading Issues
History
Resolved
January 8 7:14 PM UTC
Thank you for your patience! Students will now be able to sign in and access assignments as expected.
Investigating
January 8 5:41 PM UTC
We have been notified that students are having trouble loading Awakening to access teacher assignments. Our team is currently investigating the cause.