Teacher and Student Maintenance Message
History
Resolved
Incident has been resolved - teachers and students can now access Legends of Learning as expected. Thank you for your patience!
April 26 6:27 PM UTC
Investigating
We are currently investigating the issue of students and teachers receiving a maintenance screen when attempting to access Legends of Learning.
April 26 6:20 PM UTC