Awakening Loading Issues
History
Resolved
January 15 4:42 PM UTC
This has been resolved. Students can now access Legends of Learning as expected. Thank you for you patience!
Monitoring
January 15 4:22 PM UTC
We have identified the issue and are monitoring the fix put in place.
Investigating
January 15 4:03 PM UTC
We are currently investigating reports of Awakening not loading for students.