History

Resolved
August 29, 2024 7:15 PM UTC

Thank you for your patience! All reported issues have been resolved.

Monitoring
August 29, 2024 4:46 PM UTC

We are currently working on pushing out a fix for the issues reported today.

Identified
August 29, 2024 2:49 PM UTC

Due to some recent site updates, certain portions of our teacher platform are not functioning as expected. This includes the ability to assign work to students, student reports, and students accessing Math Basecamp. Our team has identified the cause and is working to resolve all reported issues.