Students Experiencing White Screen
History
Resolved
The issue of students receiving a white screen when attempting to access Legends of Learning has been resolved. Thank you for your patience!
April 13 3:51 PM UTC
Investigating
We are currently investigating an issue of students receiving a white screen when attempting to access Legends of Learning.
April 13 2:43 PM UTC